Show tech-support confidential

Have you ever thought of hiding sensitive information’s when sharing a show tech files?

Form Cisco IOS XE Amsterdam 17.3.x with show tech-support, Cisco introduced a keyword confidential which hide sensitive information..

show tech-support confidential : The confidential keyword was introduced, to mask sensitive information in the output of show tech-support command

When using show tech-support confidential, the output will be dumped to the router flash.

Command:- show tech-support confidential output word

  • output name of the output file where the tech-support data needs to be dumped
  • WORD flash|crashinfo:(filename) – name of output file

File will be save on your flash.

Lets compare the output of show tech-support confidential and show tech-support

show tech-support confidential

Base Ethernet MAC Address : x:x:x:x:x:x
Motherboard Assembly Number : 73-19911-04
Motherboard Serial Number : FOC25132GEG
Model Revision Number : A0
Motherboard Revision Number : A0
Model Number : C9300-24T
System Serial Number : FOC2514L6GB
CLEI Code Number :

!
ip name-server A.B.C.D A.B.C.D
ip domain name mhd.co.om
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
ip dhcp excluded-address A.B.C.D A.B.C.D
!
ip dhcp pool IPT
network A.B.C.D A.B.C.D
default-router A.B.C.D
option 150 ip A.B.C.D
!
ip dhcp pool Wireless-User
network A.B.C.D A.B.C.D
default-router A.B.C.D
dns-server A.B.C.D A.B.C.D
option 150 ip A.B.C.D
lease 0 4
!

!
interface Vlan44
ip address A.B.C.D A.B.C.D
ip helper-address A.B.C.D
!
interface Vlan45
ip address A.B.C.D A.B.C.D
ip helper-address A.B.C.D
!
interface Vlan46
ip address A.B.C.D A.B.C.D
ip helper-address A.B.C.D
!
interface Vlan47
ip address A.B.C.D A.B.C.D
ip helper-address A.B.C.D
!
interface Vlan48
ip address A.B.C.D A.B.C.D
ip helper-address A.B.C.D
!
interface Vlan49
ip address A.B.C.D A.B.C.D
ip helper-address A.B.C.D
!
interface Vlan50
ip address A.B.C.D A.B.C.D
ip helper-address A.B.C.D
!

show tech-support

Base Ethernet MAC Address : 6c:03:09:b9:da:00
Motherboard Assembly Number : 73-19911-04
Motherboard Serial Number : FOC25132GEG
Model Revision Number : A0
Motherboard Revision Number : A0
Model Number : C9300-24T
System Serial Number : FOC2514L6GB
CLEI Code Number :

ip name-server 10.5.1.200 10.5.1.100
ip domain name abc.co.om
ip dhcp excluded-address 10.12.50.1 10.12.50.30
ip dhcp excluded-address 10.12.49.1 10.12.49.30
ip dhcp excluded-address 10.12.49.200 10.12.49.254
ip dhcp excluded-address 10.12.48.1 10.12.48.30
ip dhcp excluded-address 10.12.47.1 10.12.47.30
ip dhcp excluded-address 10.12.46.200 10.12.46.254
ip dhcp excluded-address 10.12.45.1 10.12.45.30
ip dhcp excluded-address 10.12.45.220 10.12.45.230
ip dhcp excluded-address 10.12.44.220 10.12.44.254
ip dhcp excluded-address 10.12.46.1 10.12.46.100
ip dhcp excluded-address 10.12.44.1 10.12.44.50
!
ip dhcp pool IPT
network 10.12.49.0 255.255.255.0
default-router 10.12.49.1
option 150 ip 10.12.49.10
!
ip dhcp pool Wireless-User
network 10.12.48.0 255.255.255.0
default-router 10.12.48.1
dns-server 10.1.60.200 10.1.60.100
option 150 ip 10.12.49.10
lease 0 4
!
ip dhcp pool Wireless-Guest
network 10.12.47.0 255.255.255.0
default-router 10.12.47.1
dns-server 10.1.60.200 10.1.60.100
lease 0 4

interface Vlan44
ip address 10.12.44.1 255.255.255.0
ip helper-address 10.12.44.1
!
interface Vlan45
ip address 10.12.45.1 255.255.255.0
ip helper-address 10.12.45.1
!
interface Vlan46
ip address 10.12.46.1 255.255.255.0
ip helper-address 10.12.46.1
!
interface Vlan47
ip address 10.12.47.1 255.255.255.0
ip helper-address 10.12.47.1
!
interface Vlan48
ip address 10.12.48.1 255.255.255.0
ip helper-address 10.12.48.1

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s